摘录


The aar file doesn't contain the transitive dependencies and doesn't have a pom file which describes the dependencies used by the module.

It means that, if you are importing a aar file using a flatDir repository you have to specify the dependencies also in your project.

You should use a maven repository, private or public, to avoid the issue. In this case, gradle downloads the dependencies using the pom file which will contains the dependencies list.

点评

看来使用maven管理才是关键,这样就会有pom文件。

原文

点击这里查看原文

其它

本帖内容由21QA云收藏工具自动生成,欢迎使用。

系统消息 若觉得内容不错,请点击左上角的"赞"图标,以优化网站的内容呈现。 另外,请及时验证注册邮箱,否则收不到21QA发出的红包。 官方Q群:250203055

asked 16 Jun, 18:36

%E8%B7%AF%E4%BA%BA%E7%94%B2's gravatar image

路人甲
131561594671

Be the first one to answer this question!
toggle preview

powered by O*S*Q*A

粤ICP备14040061号-1